MGMT404
Lesson #1 - Basics of Project Scheduling - Part One
MS Project

V2007
Due Date: Check Class Schedule/Syllabus


Objectives 

· Understanding Project Scheduling

· Introduction to Microsoft Project

· Working with Project Tasks

· Basic views, time scales and reports

Whether you are a project manager or not, project management techniques are extremely helpful in meeting goals and objects.  Project management techniques define a path to a specified goal and then supervise the implementation. 

MS Project can help you establish your initial plan as well as monitor progress.  MS Project can quickly produce reports and other information that will help keep management, customers, and your project team informed.  To get the most from MS Project, not only do you need to understand project management terminology, you also need to be familiar with the software itself.  Therefore, do not attempt to quickly finish the lab, but take your time and read all instructions carefully.

MS Project 2003 

When you first start MS Project, a blank project file is displayed in Gantt Chart View. (If you need to open an existing MS Project file, the file extension is .mpp.) Let's take a look at the main window:
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Pay particular attention to this layout.  The Entry table is where we enter our tasks and durations.  The Gantt chart will eventually show our tasks and durations in a graphical bar chart.  The other part of significance is the divider.  This allows you to show more (or less) of the Entry table/Gantt chart.  When you start Microsoft Project, the startup task pane appears by default. This task pane also appears when you select New… from the File menu.

1. To immediately close the Task Pane, from the View menu, select Toolbars and click on Task Pane. (You can also click on the close button for the task pane).

2. You can modify this behavior so that it does not appear automatically: From the Tools menu, click Options, then the General tab. Uncheck or clear the “Show Startup Task Pane” checkbox. Then restart MS Project.

You may also notice that upon closing the task pane, another pane may appear. By default, Microsoft Project displays the Project Guide, presenting instructions and wizards in a side pane to help you define your project, work with tasks and resources, track progress, and report project information. While this can be handy at times, the screen shots for these labs will not show this guide.

1. To immediately close the Project Guide, click on the close button for the guide.

2. To permanently hide this Project Guide, From the Tools menu, click Options, then the Interface tab. Under the Project Guide settings, Uncheck or clear the “Display Project Guide” checkbox. Then restart MS Project.

[image: image2.png]D)t e e e Fome Dok Pt wedw fob

Plan and schedule your
project’s tasks by clicking an
item below. Clicking an item

displays tools and instructions
for complsting that step.

Set a date to schedule from
Define general working times
List the tasks in the project
Organize tasks inta phases
Schedule tasks

Link ta or attach mars task
information

Add columns of custom
information

Set deadiines and constrain
tasks

After planning your tasks, you
can go to the Resources area
to build your project’s team
and assign people to tasks

oo estonfor e %8 X
BT EFIEEYAR Y-S AEIAEY £ 1I=ISEY el zisen i

@ 9 & = o shou- | wid | AiTaske ey

el P
© Drasks e oo = AN TS

SM[TWITIF[S

SM[TWITIF[S

SMITWITIF[S

° rsk Nor

of

[Ready

7 =] e o




A more helpful tool is the View Bar. This graphical menu allows for quick access to the most common views you will need to complete most projects. To activate this tool, select View Bar from the View menu. 

If you have made all the changes to the configuration of MS Project indicated above, your screen should look like the screen captures in these lessons. Your final screen should look as indicated in Figure 1.

Again, please do the following:

1. Uncheck the “Show Startup Task Pane” under the General tab from the Tools/Options.

2. Uncheck the “Show Project Guide” under the Interface tab from the Tools/Options.

3. Select the View Bar from the View menu.
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Figure 1
Project Basics 

A typical project is composed of tasks and resources.  After tasks are identified, you organize the tasks in a logical hierarchy, also called a Work Breakdown Structure (WBS).  Eventually, this sequence will show the interdependencies of each task. Then each task is given a duration.  In MS Project, this can be in months, weeks, days, hours or minutes.  You can also specify a milestone, which will represent an event that marks the completion of a group of related tasks.  

To accomplish any task, you need resources.  Resources can include people, equipment, material or special facilities necessary to complete a task.  Resource availability and scheduling are important constraints to completing a task.  

Once you establish a plan, complete with tasks and resources, you will often need to refine the plan before saving it as a baseline.  The baseline is your guideline to help manage the project.

To understand the overall project management philosophy, let's take a tour using MS Project On-line help: (you will need Internet access to do this).
1. Log onto Windows.

2. Open MS Project by selecting the Start Button and choosing MS Project from the Programs menu. (It may be listed under MS Office or separately).

3. From the Help menu, select Microsoft Project Help.
4. Under the search textbox for Assistance, click on Table of Contents. 
5. Choose Creating a Project Plan, and then click on The Project Map.
6. Click on “The Project Map: your roadmap to project management.
7. Once you have thoroughly read through these sections (remember some of the answers to questions from the end of each lesson come from this material), close the window and the help pane and return to MS Project main window. (Your screen should look like Figure 1).
Keep in mind this is a very brief look at establishing a project with MS Project.  Over the next few lessons, we will try to explore as many aspects as we can. 

The first step in creating a project is establishing the project information.

1. Select Project Information from the Project menu
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The Project Information is used for information that is critical to the scheduling of tasks and resources.  It contains the start date and finish date of the overall project, the current date (taken from the computer), and which calendar you will be using.  You must always enter this information when creating a new project.

2. Enter the starting date of this project as October 1, 2007.  (Note: you can only enter the start date or the finish date, but not both!).  
3. Leave the other information as is and Press OK.
4. From the File menu, click Properties.  The Summary tab should be selected. 
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5. In the Title box, type Maynard Furniture Company Project.
6. In the Subject box, type New System.
7. In the Author's and the Manager's box, type in your name.  This information will be displayed on reports.  In the Company box, enter MGMT404 followed by your section letter (such as A, B...), followed by your professor’s name. Click OK.
8. Save the project as MyLab1_XXX.mpp (where XXX are your initials).
Entering tasks 

1. Click in the first field in the Task Name column.  Type Inventory current equipment.

2. Press tab.  The information is entered and the selection moves to the Duration column for task 1. Notice that 1 Day? is the automatic default for duration.  (You may need to slide the divider to the right to see the column).  Also notice the task is represented on the Gantt chart. 
3. Change the duration to 3 days by typing 3 and press enter. Notice the duration "days" or the letter "d" is automatically assumed.  If different, you would enter m for minutes, h for hours, d for days, w for weeks or mo for months after the number, such as 3w would be three weeks).
4. Enter the following tasks and durations for this project:
Access current department needs
2 days

Design and diagram new system
5 days

Create proposal for accounting
3 days

Research products and services
7 days

Issue RFPs


7 days

Evaluate bids


5 days

Award contract


1 day 
(You should always enter the 1 day)

Plan work with vendor

1 day
(Do not use the default of “1 Day?”)

Purchase equipment

4 days

Install wiring


3 days

Install hardware


2 days

Install software


2 days


(Note: it is very important that you make any changes to these durations BEFORE assigning resources.  If you need to change duration after assigning resources, you should unassign all resources, change the duration and then re-assign the resources!)

5. Notice as you enter each task and the duration, how the tasks are presented on the Gantt chart.

(Tip: You may not be able to read the entire task names after entering the name, not very professional. To see the entire task name, position your cursor on the vertical line between the Task Name column header and the Duration column header.  When the cursor turns to a double arrow, either drag the line to the right to increase the column width or double-click.  Another method is to double click on the Task Name column header and select Best Fit.  To see the Duration column, move the divider between the tasks and the Gantt chart).

. 
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6. Change the duration of the task Award Contract to 0 days.  Notice the ♦ symbol on the Gantt chart.  This is a milestone task, which usually has no duration but is used to mark progress in a project.

7. What if you need to insert a task later? Easy.  For example, select task #13, Install Software. Then from the Insert menu, click New Task.  A new task row will now be inserted above the current task.  

8. Type Test system as your new task and enter duration of 1 day. (Remember to always enter 1; do not have the “?” in your duration!)


9. Since “Test system” actually should be our last task, we need to move it.  Therefore click (but do not hold down the mouse button) the task ID for task #13 - Test system.  The entire row should be selected.
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10. With the pointer still positioned on the task ID, drag down until a horizontal gray bar is displayed after task #14.  Then release.  Test system should now be your last task.
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11. What if you want to delete a task?  Click anywhere in the row for the task Plan work with vendor.  From the Edit menu, click Delete Task.
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Another type of task you may want to enter is a recurring task, such as a team meeting, etc.  Generally recurring tasks are not included on a project, but may help in resource scheduling.

12. Below the last task (task #13: Test System), click in the Task Name Column, but do not type anything.
13. From the Insert menu, click Recurring Task.  The Recurring Task Information Box appears.
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14. In the Name box, type Project Meeting.
15. Press tab and enter 2h for duration of 2 hours. Select Weekly for "Recurrence pattern" and check the box for Friday.  Leave "every".  We have scheduled a weekly 2-hour meeting every Friday for the duration of the project. Click OK. (Notice the circular arrows in the indicator column next to the task name).
16. Save the project before continuing.  
Displaying Project Information in Views 

Before closing out this project, we need to spend a little time with views.  A view is a format in which you can enter and/or display information in MS Project.  Your default view is known as the Gantt view: it is made up of the Entry table on the left, used to enter task information, and the Gantt chart on the right, which graphically represents the task information on a timescale.  

Task and resource views in MS Project fall into three basic categories: sheet views, chart and graph views, and form views. Each view displays combinations of project information in different ways.  Understanding what is your current view and changing views is critical in mastering MS Project.

Sheet views display task or resource information in a row and column format (similar to MS Excel).  Chart and graph views provide a graphical representation of task or resource information.  Form views display task or resource information in a format that displays a single task or single resource at a time.  You use a form view when you want to focus on detailed information about a specific task or resource.

MS Project comes with many predefined views.  Each view can be displayed using the View menu or the View Bar located on the left side of the MS Project program window.  To see some of these views:

1. From the View Bar, click the Calendar icon.  (Or select Calendar from the View menu). What do you see?
2. Now click the Task Usage icon.  How is this different?
3. Finally, click the Network Diagram icon.  Graphical view of tasks…
4. Return to the Gantt Chart view.
5. You can hide the View Bar if you need more room.  On the View menu, click View Bar.  Notice the View Bar disappears and is replaced by a blue, active bar on the left side of the screen that displays the name of the current view (Gantt Chart).  
6. To display the View Bar again, on the View menu, click View Bar.  Notice the Gantt chart icon is selected in the View Bar.
7. Another item to explore is the timescale for the Gantt chart.
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On longer projects, you may not be able to see all the tasks on the Gantt chart.  You can use the scroll bars to the right and on the bottom of the Gantt chart or you can adjust the timescale of the chart (shown above).  The top line of the timescale is referred to as the Major timescale (Oct 1,'06, etc.) and the bottom line as the Minor timescale (SMTWTFS).  To adjust the timescale, you can use the Zoom In and Zoom Out buttons on the Standard toolbar. 

8. On the Standard toolbar, click the Zoom In button ONCE (the one with the + sign).  Notice the Major timescale changes to a day and the Minor timescale changes to 6-hour increments.  

9. Now click on the Zoom Out button Once (the one with the - sign).  The Major timescale returns to a week and the Minor timescale changes to day increments.

10. Click on the Zoom Out button again.  Notice the Major timescale changes to a month and the Minor timescale changes to 3-day increments.

11. Click the Zoom In button again to return to the default of a week and one-day increments.

You can also specify your own timescale by selecting the Timescale dialog box on the Format menu or selecting Zoom from the View menu.

Printing Project Schedules and Reports

To manage a project effectively, you will need to communicate project information to a variety of people.  You can print views and reports that meet the needs of a specific person or group.  MS Project comes with many predefined views and predefined reports.  Before you print a view or report, it should be previewed to determine the number of pages that will be printed and if any additional information needs to be added.

Using the Page Setup dialog box, you can select page orientation, adjust scaling, change margins, and add or change the headers and footers.  You can also add page breaks to control the flow of information.  You can also create a legend at the bottom of the Gantt chart to explain the symbols used in the chart. 
Important notice for this and all labs:

(With the exception of the Project Summary report, you must do the following for each report/printout; it is NOT a universal page setup!)

1. On the File menu, click Page Setup. Click the Header tab.
[image: image12.png]b | Maohs | tesdsr | Footer | Legend | vew
e
Homerts Lot Contr gt
Al @l 68 @l el @l =
Genepli [o e B
Project fildsi [ Complete ]
ik revi.. | _options i e ==





2. The top pane is the Preview box and the bottom pane is the Text box.

3. Select the Left tab next to Alignment.  In the Text box, type Lab #1 on the first line. (The left corner will always be the lab number, so make sure you change it in future labs!)

4. Select the Center tab.  (Delete any entries that may already be there)

5. Next to the General box displaying the text, "Page Number", click the down arrow and select Project Title.  Click Add.  

Note: the project title is displayed in the Preview box (based upon the information you entered in the Project Information earlier).  The text box shows the “&” sign or the "place marker" for this information.  The nice thing here is that if you ever change the Project Information, the changes will automatically appear on any reports that contain this information in the header.

6. Press Enter.  (The cursor should now be on the second line for your center header information). From the same drop-down menu, add Manager Name.  Press Enter and add File name as your third line and add Report Name as your fourth and final line.
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7. Select the Right tab.  Notice the seven icons below the text box.  Select the middle (or fourth icon) to insert the current date in this section of your header.

8. Press Print Preview to view the changes.  What is missing?  Notice that there is nothing displayed in the fourth line of the header for report name?  Why???  This is a view and not a defined report so there is nothing to display in this field.  In order to see the view name, the parameter in the fourth line of the header would have to be changed to View Name – we will NOT do this at this time.  The fourth line will display as a blank line when we are in a view format and not a report format.  

9. Click the Close button to return to the Gantt chart view.

10. The above page setup must be on all your printouts for this and all future lessons!  Failure to do so will result in points subtracted from your lesson score!! Remember also, that this is NOT a universal set up, each report and view will need to be done separately.
Previewing and Printing Views and Reports 

11. On the Standard toolbar, click the Print Preview button.  Place the mouse pointer over the preview page.  The pointer changes to a magnifying glass.
12. Click the lower-left corner of the preview page.  The view is zoomed in so you can see the legend to the Gantt chart.  If you ever want to change the contents of this legend, you can go to the same Page Setup in our previous steps and select Legend.  
13. Click on the magnifying glass again to return to normal view. Make sure the task names column and the duration column can be seen in their entirety and the Gantt chart also appears in your window.
14. Click Print and print this view. We have just printed the Gantt chart view. 
15. To view and print reports: From the View menu, click Reports.
[image: image14.png]Reports

_d

T

=

Select

Overview. Current Activities. Costs.

Close





16. The Reports box opens.  Each icon represents a category of reports.  The first five (Overview, Current Activities, Costs, Assignments and Workload) represent 22 predefined reports.  The last category, Custom, allows you to create your own report.
17. Select Overview and then select Project Summary.  The Project Summary report now opens in Print Preview.  
18. Select Page Setup for this report.  Notice something interesting?  The header and footer (and legend and view) tabs are grayed out.  For some reason, only known to Microsoft, this is the only report that you cannot change the header and footer.  To that end, it is imperative that you enter all appropriate project information and project properties as discussed in the lab!
19. Print the Project Summary.  This is a very important report!  It lists all relevant summary information as to project progress and achievement of your project objective.
20. On your own, find the report, Unstarted Tasks.  Before you print this report, make sure your header contains the appropriate information and format!  Print the report when all is well.

21. Save your file and exit MS Project.

In the next lesson, we will continue working with task information by outline and linking these tasks and discussing interdependencies and constraints.

1. On the Project menu, click Project Information.  In the Project Information dialog box, click Statistics.  The following screen should appear.  Use this to check your progress…
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Review Questions

Name ____________________________

Answer the following questions in complete sentences. (You will need to use MS Project’s On-line Help. Make sure you have an Internet connection).  Write legibly.

1. Define the following terms according to MS Project Help and Project Road Map: 

Project Objectives: 



Deliverables:
Task: 

Duration:

Schedule: 
Tables: 
2. What is a milestone? 




3. What predefined report can you not make changes in the header and footer?

Attach your three printouts, in print order, to the back of this sheet and submit by the lesson due date.
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